OpenVPN

Install required packages

opkg install openvpn-openssl luci-app-openvpn

Copy .ovpn and .auth files to /etc/openvpn. Then add the following to /etc/config/openvpn.

config openvpn 'metromarkets'
  option config '/etc/openvpn/metromarkets.ovpn'
  option enabled '1'

/etc/config/network

Append the following:

config interface 'tun0'
  option ifname 'tun0'
  option proto 'none'

/etc/config/firewall

Add the interface tun0 to the wan zone.

[...]

config zone
  option name 'wan'
  option input 'REJECT'
  option output 'ACCEPT'
  option forward 'REJECT'
  option masq '1'
  option mtu_fix '1'
  option network 'tun0'

[...]